Minimum PHP version for WordPress

Last Revised: October 2, 2021

For a few versions of WordPress, all those plugin developers can indicate the minimum version of PHP necessary for it to work. WordPress is putting a lot of effort into keeping all its products and services up to date and with updated versions, and that involves the developers themselves, as reported in August 2017.

The idea is that in the header of the plugin the minimum version is indicated with a line:

=== Plugin Name ===
Contributors: (this should be a list of userid's)
Donate link:
Tags: comments, spam
Requires at least: 4.6
Tested up to: 4.8
Requires PHP: 5.6
Stable tag: 4.3
License: GPLv2 or later
License URI:

In this case, the text Requires PHP: 5.6 is indicated in which it is reported that the minimum operating version of the plugin is 5.6; therefore, those users who have older versions of PHP on their system will receive a warning as it may not work or directly block the possible installation.

In the plugin repository, in addition, a version notice will appear in the technical information area.

Seguir con Seguridad para WordPress

About this document

This document is regulated by the EUPL v1.2 license, published in WP SysAdmin and created by Javier Casares. Please, if you use this content in your website, your presentation or any material you distribute, remember to mention this site or its author, and having to put the material you create under EUPL license.